EasyBox 904 LTE APN ändern

An dieser Stelle möchte ich euch erklären, wie man an der EasyBox 904 den APN ändern und die Box somit auch für andere Provider freigeben kann.

Hintergrund an der Sache war bei mir, das ich mir eine Backup Internetanbindung im Netzwerk erstellen wollte, die mich im Bedarfsfall zumindest über LTE online bringt. In der aktuellen Situation durch Corona und dem damit verbundenem Home Office kann eine Backup Verbindung nicht das schlechteste sein.

Die EasyBox 904 LTE ist für recht kleines Geld, meist unter 20€ im Netz zu finden. Durch die 4 Gigabit Ports und dem 300MBit WLAN ist sie auch noch recht brauchbar.

Was benötigen wir?

Vorgehensweise:

1. Ermitteln der IMSI Nummer der Simkarte Auslesen der IMSI Nummer geht am leichtesten mit einem Handy, welches aber kein Android 10 als Betriebssystem haben sollte. Im Play Store sucht ihr nach dem Tool Network Info II, installiert und startet dieses. Im Abschnitt Device findet ihr dann die IMSI Nummer.
Ähnliche Tools gibt es auch für IOS, dort einfach mal googeln.

2. Aufspielen der Firmware

  • Die EasyBox mit LAN Kabel verbinden und starten
  • Browser öffnen und über http://192.168.2.1 oder http://easy.box das Konfigurationsinterface öffnen. Sollte das nicht klappen, Box über Resetknopf an der Rückseite einfach auf Werkseinstellung zurücksetzen. Das Passwort zur Anmeldung lautet 123456

 

Nach der Anmeldung den Menüpunkt Extras aufrufen, dort findet sich der Punkt Firmwareaktualisierung

Über die manuelle Firmware-Aktualisierung die Firmware Datei aus dem Link auswählen und Update durchführen. Nachdem die Aktualisierung abgeschlossen ist, Box ausschalten, paar Sekunden warten und wieder einschalten.

Wieder anmelden und unter Status & Hilfe dann Diagnose-Tool wählen. Bei Ping-Test nun folgende Daten eintragen:

192.168.2.1 & telnetd


Jetzt ist die Box soweit vorbereitet, das wir uns mit Putty auf die Box verbinden können.

Dazu Putty starten, Telnet wählen und die IP-Adresse 192.168.2.1 eintragen, dann open


Zum Anmelden folgende Daten nutzen

Benutzer: root

Passwort: 123456

Kommen wir jetzt zu dem Teil mit den erforderlichen Telnet Befehlen:

Aktivierung der EasyBox

ccfg_cli set ivr_mode@bootstrap=2
ccfg_cli set arcor_pinConf@bootstrap=1
ccfg_cli set arcor_customer@bootstrap=1
ccfg_cli set keep_in_act@bootstrap=0
ccfg_cli set FirstUseDate@tr69=2018-08-27T19:26:49
ccfg_cli set Username@tr69=IMSI-Nummer
ccfg_cli set IMSI@lte=IMSI-Nummer
ccfg_cli commitcfg

An den zwei rot markierten Stellen bitte die von euch ermittelte IMSI-Nummer eintragen!!

APN für O2

ccfg_cli set umts_lock_ops@lte=26203
ccfg_cli set lte_lock_ops@lte=26203
ccfg_cli set umts_lock_ops@wan200=26203
ccfg_cli set lte_sim_lock_ops@lte=26203,26205,26207,26208,26211,26277
ccfg_cli set apn_data@lte=internet
ccfg_cli set apn_voice@lte=internet
ccfg_cli set apn_umts@lte=internet
ccfg_cli set username@lte=
ccfg_cli set passwd@lte=
ccfg_cli set username@umts=
ccfg_cli set passwd@umts=
ccfg_cli commitcfg

APN für Telekom

ccfg_cli set umts_lock_ops@lte=26201
ccfg_cli set lte_lock_ops@lte=26201
ccfg_cli set umts_lock_ops@wan200=26201
ccfg_cli set lte_sim_lock_ops@lte=26201,26206
ccfg_cli set apn_data@lte=internet.home
ccfg_cli set apn_voice@lte=internet.home
ccfg_cli set apn_umts@lte=internet.home
ccfg_cli commitcfg

APN für Vodafone

ccfg_cli set umts_lock_ops@lte=26202
ccfg_cli set lte_lock_ops@lte=26202
ccfg_cli set umts_lock_ops@wan200=26202
ccfg_cli set lte_sim_lock_ops@lte=26202,26204,26209
ccfg_cli set apn_data@lte=web.vodafone.de
ccfg_cli set apn_voice@lte=web.vodafone.de
ccfg_cli set apn_umts@lte=web.vodafone.de
ccfg_cli commitcfg

Box ausschalten, einige Sekunden warten, Box wieder einschalten und starten lassen.

Jetzt sollte der APN geändert sein.

40 Kommentare

  • Marc

    Hallo,

    habe genau das gleiche Problem wie Hendrik. Habe alles so gemacht wie in der Anleitung steht. Box steht dann auch nicht mehr auf „bitte aktivieren“ sondern ist aktiviert. Bei Internet steht dann aber ein rotes ausrufezeichen wie auch am Anfang.

    Es geht um O2

    Habe ich so genommen wie oben steht:
    ccfg_cli set umts_lock_ops@lte=26203
    ccfg_cli set lte_lock_ops@lte=26203
    ccfg_cli set umts_lock_ops@wan200=26203
    ccfg_cli set lte_sim_lock_ops@lte=26203,26205,26207,26208,26211,26277
    ccfg_cli set apn_data@lte=internet
    ccfg_cli set apn_voice@lte=internet
    ccfg_cli set apn_umts@lte=internet
    ccfg_cli set username@lte=
    ccfg_cli set passwd@lte=
    ccfg_cli set username@umts=
    ccfg_cli set passwd@umts=
    ccfg_cli commitcfg

    oder muss bei username und passwd was eingetragen werden ? Wenn ja was denn ? Hat jemand einen Tipp für mich ? Hatte mich so gefreut und 2 Boxen gekauft und jetzt läuft es nicht mit O2 🙁

    • Teste es bitte mal mit diesen Daten
      ccfg_cli set umts_lock_ops@lte=26207
      ccfg_cli set lte_lock_ops@lte=26207
      ccfg_cli set umts_lock_ops@wan200=26207
      ccfg_cli set lte_sim_lock_ops@lte=26203,26205,26207,26208,26211 ,26277
      ccfg_cli set apn_data@lte=internet
      ccfg_cli set apn_voice@lte=internet / pinternet.interkom.de
      ccfg_cli set apn_umts@lte=internet
      ccfg_cli set username@lte=
      ccfg_cli set passwd@lte=
      ccfg_cli set IMSI@lte= IMSI_NUMMER
      ccfg_cli set Username@tr69= IMSI_NUMMER
      ccfg_cli commitcfg

  • joe

    hallo jemand zufällig daten für ortel mobile – home flat ? danke

  • Herbert

    Hallo Joachim,

    funktioniert das auch mit einer SIM-Karte von WindTRE (Italien)?
    Muß ich da bei (Vodafone oder Telekom) etwas anderes eingeben?

    Und … die rot markierten Stellen sind leider nicht mehr da, soll man
    anstatt: „IMSI-Nummer“ die ermittelte IMSI-Nummer eintragen?

    Vielen Dank,
    Herbert

    • Moin Herbert,

      leider kenne ich die erforderlichen Daten für WindTRE nicht, daher kann ich dir nicht sagen, ob und was dort geändert bzw. eingetragen werden muss.

      Die rot markierten Stellen sollten wieder da sein. Dort muss die ermittelte IMSI-Nummer eingetragen werden.

  • Th.Frank

    Danke für die tolle Anleitung ….hat perfekt geklappt .
    Wenn ich jetzt das aktuelle Firmawareupdate drüber bügel , sind die APNs dan wieder die alten oder bleiben diese erhalten ??

    Grüsse

    • Moin,

      ein andere User hat wohl danach ein Firmware Update probiert, soll wohl nicht gehen. Steh in einem der unteren Kommentare. Ich selber habe es noch nicht ausprobiert, da ich das Gerät auch nicht mehr im Einsatz habe.

  • Helmut-2

    PuTTY-Login funktioniert bei mir nicht.
    Inhalt PuTTY-Log-Datei putty.log:
    „=~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2022.02.11 19:42:52 =~=~=~=~=~=~=~=~=~=~=~=
    easy.box login: root
    Password:
    Login incorrect
    easy.box login: root
    Password:
    Login incorrect
    easy.box login: “

    Habe vorher ein Firmware downgrade von V …3.21 über …3.18 auf …3.07 durchgeführt.
    Direkt von V .. 3.21 auf ..3.07 hat ncht funktioniert

    Gibt es ein alternatives LogIn oder einen Tip, wie ich ggf. weiterkomme?

    • Du nutzt als Password 123456 oder ein anderes?

      • Helmut-2

        Ja, ich habe 123456 gefolgt von ENTER als Password eingegeben.

      • Helmut-2

        Das mit dem Password war mein Fehler, ich hatte der EasyBox schon ein anderes verpasst.
        Nach Werkseinstellung laden Anlegen des neuen Passwords 123456 bin ich bei Putty weiter gekommen.
        Wahrscheinlich habe ich nicht die richtige IMSI-Nummer, denn nach dem Aus-/Einschalten der Box kommt der Hinweis, „Die SIM-Karte wurde gewechselt, … Werkseinstellung muss geladen werden“
        Nach laden der Werkseinstellung sind dann die APN wieder wie vorher.

      • Helmut-2

        Ist die IMSI-Nummer identisch mit der auf der SIM-Karte aufgedruckten Kartennummer
        bzw. der ICCID, der hintere Teil der ICCID(ohne die forderen 6 Ziffern) ist identisch mit der aufgedruckten Nummer?
        Mit dieser habe ich weiter probiert.
        Ich habe s immer noch nicht hinbekommen.
        Ich habe die Firmware V ..3.07 übertragen und danach die Änderungen mit Putty vorgenommen.
        Nun erscheint nach Ein-/Aus der EasyBox kurz das Fenster zur Eingabe der SIM-Pin, das wird aber sofort
        überschrieben mit: „Die SIM-Karte wurde gewechselt, … Werkseinstellung muss geladen werden“
        Der Übergang zwischen den beiden Ausgaben ist mal kaum merklich manchmal etwas länger, reicht aber nicht zur PIN-Eingabe.
        Gibt es dafür eine Lösung oder einen Hinweis?

        • Moin Helmut,

          die IMSI ist nicht identisch mit der SIM Karten Nummer oder der IMEI Nummer.

          Schau mal hier, vielleicht hilft dir das weiter. Es gibt Mittel und Wege diese Nummer auszulesen.
          https://www.kolja-engelmann.de/blog/2012/06/imsi-auslesen-unter-android-und-ios/

          • Helmut-2

            Danke für die Antwort Joachim,
            der Kolja Engelmann aus Deinem Link schreibt am Ende, das die IMSI bei ihm auf die SIM-Karte gedruckt war. Desshalb meine Vermutung.
            Meine SIM hätte dann den Ländercode(282 15) von Georgien, das hat mich stutzig gemacht.
            Habe leider z.Z. nur iOS-Geräte, „Jailbreak“ will ich erst mal nicht.

          • Helmut-2

            Vielen Dank für die gute Beschreibung Joachim.
            Zwei Varianten zum lesen der IMSI habe ich getestet:
            1.) altes Siemens SXG75 + SW „mobileMaster“ unter WinXP
            2.) älteres Smartphone mit Android V5.1 + App „Network Info 2“
            Die erste Variante ist recht umständlich, da auch noch ein passendes USB-Kabel nötig ist.
            Da ich schon Einiges probiert hatte, hat es wahrscheinlich mit der richtigen IMSI nicht sofort funktioniert.
            Ich habe dann zuerst die Firmware V3.18 und dann die V3.07 noch einmal drübergebügelt.
            Die Aktualisierung der V3.07 hat dann gefühlt eine Ewigkeit gedauert.
            Danach war die neue APN-Einstellung OK und die Eingabe der SIM-PIN hat funktioniert.

  • Georg

    Hallo,
    nachdem ich in putty „easy.box login: root“ eingegeben habe lässt sich das Password nicht eingeben. Ich hab´s auch schon über windows + r/ cdm telnet 192.168.2.1 (telnet ist in der Systemsteuerung aktiviert), genau das selbe,
    „easy.box login: root“ Password Eingabe funktioniert nicht. An was liegt das? Kann man die Passwordeingabe irgendwie
    aktivieren? Hat jemand ´ne Idee?

    • Einfach 123456 und Enter, es wird keine Anzeige am Bildschirm angezeigt bei der Eingabe.

      • Georg

        Alles klar, danke.

      • Georg

        Moin erstmal,
        mit Freenet funktioniert das Internet erstaunlich flott, flotter als mit meinem Huawei B315s-22. Trotzdem habe ich noch Fragen.
        1. Telefonieren über die Analog Anschlüsse funktioniert trotz Freenet Telefonflat,
        anders als beim Huawei, leider nicht.
        Gibt´s ein Modem für die Easybox damit das Telefon funktioniert?
        2. Wie lautet die Konfiguration für das 1&1 D1 Netz (nicht das LTE!)?
        3. Kann ich die Box über Putty so konfigurieren, daß ich die Simkarten wechseln kann wie bei einem Sim Lock freien Router? Z.B. in dem ich nach der Aktivierung 2 oder mehr Konfigurationen nacheinander eingebe?
        4. Kann man nach dem entsperren ´ne Firmware Aktualisierung durchführen oder besser die 3.07 bei behalten.
        Ich denke das war´s soweit. Danke im voraus.
        MfG

        • 1. Telefonieren über die Analog Anschlüsse funktioniert trotz Freenet Telefonflat,
          anders als beim Huawei, leider nicht.
          Gibt´s ein Modem für die Easybox damit das Telefon funktioniert?
          – Leider kann ich dir die Frage nicht beantworten, nach meinem Stand unterstützt die Box das nicht.

          2. Wie lautet die Konfiguration für das 1&1 D1 Netz (nicht das LTE!)?
          – Muss ich selber erst suchen, leider habe ich keine aktuellen Daten dafür

          3. Kann ich die Box über Putty so konfigurieren, daß ich die Simkarten wechseln kann wie bei einem Sim Lock freien Router? Z.B. in dem ich nach der Aktivierung 2 oder mehr Konfigurationen nacheinander eingebe?
          – Habe ich noch nicht probiert, ob sich letztliche alle Provider dort eintragen lassen.

          4. Kann man nach dem entsperren ´ne Firmware Aktualisierung durchführen oder besser die 3.07 bei behalten.
          – Habe ich noch nicht ausprobiert, habe das Gerät auch nicht mehr in der Nutzung, so das ich es testen könnte.

        • Georg

          zu 2. „Konfig 1&1 D1 Netz….
          ist die APN Vodafone, wie oben (sieht man ja an der IMSI 26202….)
          zu 4. Aktualisieren…..
          online getestet, keine Aktualisierung auf 3.18 möglich, zeigt 3.07 neueste Firmware.

  • matze

    Hallo . Mache alles wie beschrieben aber es stehen immer noch die alten APN in der Box ???Nix geht. Wie ich das verstehe , nach jeder Befehlszeile enter drücken und am ende „ccfg_cli commitcfg“ und enter . Die Box scheint das nicht zu nehmen . Die eingegebene IMSI sehe ich aber in der Box …..Hilfe

  • Benito

    Hallo, ich will die Box für Telkom umstellen was genau muss ich dann eingeben ?
    Mfg und Danke für die Hilfe

    • Für Telekom sollte der Teil funktionieren
      ccfg_cli set umts_lock_ops@lte=26201
      ccfg_cli set lte_lock_ops@lte=26201
      ccfg_cli set umts_lock_ops@wan200=26201
      ccfg_cli set lte_sim_lock_ops@lte=26201,26206
      ccfg_cli set apn_data@lte=internet.home
      ccfg_cli set apn_voice@lte=internet.home
      ccfg_cli set apn_umts@lte=internet.home
      ccfg_cli commitcfg

  • Lukas Richter

    wie kann ich nun telefonieren mit der box? leider wird mir ein ausrufezeichen angezeigt bei telefonie

  • Lukas Richter

    Login dauernd incorrect… Bitte brauche hilfe

  • joshua mis

    hallo warum komme ich nicht bei dem Ping test weiter ? Dort steht immer ich solle die gültige IP eingeben obwohl das kopierte von dir ja stimmt

    • Nachdem du den Pingtest gestartet hast, einfach Telnet auf
      rufen und dort die IP 192.168.2.1 nehmen, der Test dient lediglich dazu, das die IP 192.168.2.1 über Telnet erreichbar wird. Das Ergebniss des Test ist unrelevant.

  • Tim

    hi, hast du am Ende, nach Eingabe der APN des jeweiligen Provider, nicht noch ein „ccfg_cli commitcfg“ vergessen?
    Das bedeutet ja quasi speichern und muss ganz am Ende noch einmal ausgeführt werden 🙂
    zumindest habe ich es nicht ausgeführt und war lange am Fehlersuchen 😉
    Gruß

    PS: Ansonsten super Blog, thumps up

  • Hallo,
    bei mir sagt er das ist keine gültige Firmware und bricht ab.
    Die jetzige ist:
    Aktuelle Firmware-Version:AT904L-03.21 (Linux 2.6.32.32 #1 Wed Mar 11 03:17:51 CST 2020)

    Grüße

    • Sorry, hatte vergessen die Datei zu entpacken.
      Jetzt scheitert es an Pin-Test:
      Ping-Test abgebrochen

      Der Ping-Test konnte nicht durchgeführt werden. Bitte überprüfen Sie die eingegebene IP-Adresse und versuchen es erneut.

      Da weiß ich jetzt auch nicht mehr weiter..

      • An der Stelle wo Ping-Test ausgeführt wird, wechseln zu Putty, an der Box ist weiter nichts zu machen. Der Test ist im Grunde nur das Einstiegstor, damit du per Putty zugreifen kannst.

        • Ok, habe ich gemacht.
          Kann mich mit putty einloggen, habe auch die Befehle abgesetzt aber keine Reaktion.
          Was muss ich eingeben für vodafone callya? IMSI habe ich.

          • Aktivierung der EasyBox

            ccfg_cli set ivr_mode@bootstrap=2
            ccfg_cli set arcor_pinConf@bootstrap=1
            ccfg_cli set arcor_customer@bootstrap=1
            ccfg_cli set keep_in_act@bootstrap=0
            ccfg_cli set FirstUseDate@tr69=2018-08-27T19:26:49
            ccfg_cli set Username@tr69=IMSI-Nummer
            ccfg_cli set IMSI@lte=IMSI-Nummer

            An den zwei rot markierten Stellen bitte die von euch ermittelte IMSI-Nummer eintragen!!

            ccfg_cli set umts_lock_ops@lte=26202
            ccfg_cli set lte_lock_ops@lte=26202
            ccfg_cli set umts_lock_ops@wan200=26202
            ccfg_cli set lte_sim_lock_ops@lte=26202,26204,26209
            ccfg_cli set apn_data@lte=web.vodafone.de
            ccfg_cli set apn_voice@lte=web.vodafone.de
            ccfg_cli set apn_umts@lte=web.vodafone.de

            Danach neustarten und es sollte alles funktionieren.
            Habe es an mehrerern Geräten bereits so gemacht.

  • Henrik

    Hallo, habe anhand dieser Anleitung versucht, die easyboy auf o2 umzustellen, leider erfolglos. Die APN ist laut Webinterface auf „internet“ geändert, 15-stellige IMSI wird angezeigt, LTE Signal ist da, aber die Box verbindet sich nicht. Sim Karte (postpaid) funktioniert im Handy 1a. Hatte die Box vor einiger Zeit bereits auf vf pepaid umgestellt, das klappte. Hatte sie nun vor der o2 Umstellung extra auf Werkseinstellungen zurückgesetzt, aber erfolgslos. Eine Idee, woran es haken könnte?

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht.

Diese Website verwendet Akismet, um Spam zu reduzieren. Erfahre mehr darüber, wie deine Kommentardaten verarbeitet werden.